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TheAltera SoC integrates anARM®Cortex®-A9-based hard processor system (HPS) consisting of processor,
peripherals, and memory interface with the FPGA fabric using a high-bandwidth interconnect backbone.
The Cyclone V® HPS Interface provides up to 67 I/O pins to share with multiple peripherals through sets
of configurable multiplexers. The Arria V Interface provides up to 71 I/O pins.

This application note describes the steps required to route an HPS peripheral through the FPGA interface
using Qsys and Quartus II software. A simple design example is included to demonstrate exporting HPS
EMAC0 and I2C0 peripheral signals to the FPGA interface using a Cyclone V SoC Development Kit.

HPS Peripherals That Support Routing to the FPGA
The types of peripherals in the HPS that are capable of routing to the FPGA fabric are:

• Ethernet Media Access Controller (EMAC)
• Quad Serial Peripheral Interface (QSPI)
• Serial Peripheral Interface (SPI)
• Universal Asynchronous Receiver/Transmitter (UART)
• Inter-Integrated Circuit (I2C)
• Controller Area Network (CAN)

In many cases, routing the HPS IP signals to the FPGA external interface allows more signals to be exposed.

Table 1: Peripherals that Support Signal Routing from the HPS Domain to FPGA Domain

The following table lists the interface type that is available depending on whether the IP interface is pinned out in
the HPS domain or the FPGA domain.

Interface DescriptionPeripherals

FPGA DomainHPS Domain

GMII InterfaceRGMII InterfaceEMAC

StandardQSPI interface with four
slave select signals achieved by
connecting exported signals to
bidirectional buffers

Standard QSPI interface with four
slave select signals

QSPI

ISO
9001:2008
Registered
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Interface DescriptionPeripherals

FPGA DomainHPS Domain

MOSI/MISO SPI interface with
output enables that support up to
four slaves; interface achieved by
connecting exported signals to
bidirectional buffers

MOSI/MISO SPI interface
configurable to single or dual slaves

SPI Master

MOSI/MISO SPI interface with
output enables that support up to
four slaves; interface achieved by
connecting exported signals to
bidirectional buffers

MOSI/MISO SPI interface
configurable to single or dual slaves

SPI Slave

Standard UART interface with
flow control signals, including
DTR and DSR; status and two
user-defined output signals are
also available

Standard UART interface with flow
control signals

UART

Standard I2C interface achieved
by connecting exported signals to
a bidirectional buffer

Standard I2C interfaceI2C

Standard CAN interfaceStandard CAN interfaceCAN(1)

Please refer to the following Cyclone V Device Handbook chapters for descriptions of each peripheral signal
interface:

Related Information

• Ethernet Media Access Controller

• Quad SPI Flash Controller

• SPI Controller

• UART Controller

• I2C Controller

• CAN Controller

(1) The CAN interface is only available for Cyclone V devices.
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HPS IP Interface to FPGA Design Example
This design example, based on the Golden System Reference Design (GSRD), uses the Cyclone V SoC
development kit resources to demonstrate routing theHPS EMAC0 and I2C0 peripheral signals to the FPGA
interface.

The HPS component provides up to two EMAC peripherals, which support 10/100/1000 Mbps operation.
The Cyclone V SoC Development board is populated with a Micrel KSZ9021RN RGMII PHY that interfaces
to the HPS domain and a Renesas uPD60620A MII Dual Port PHY that interfaces to the FPGA domain. The
HPS and FPGA also share a common I2C bus to various on-board I2C slaves.

Figure 1: High-level Routing Layout of Cyclone V SoC Board Design Example
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The following sections provide the necessary information to route theHPS peripherals to the FPGA interface,
such as:

1. Prerequisites on page 4

2. Getting Started on page 5

3. Generating the Initial HDL in Qsys on page 5

4. Top Level Routing on page 8

5. Timing Constraint Configuration on page 10

6. Quartus II Pin Assignments on page 10

7. Hardware Programming File Compilation and Generation on page 12

8. SD Card Image Updates on page 12
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9. Board Setup and Booting Linux from the SD Card on page 13

Prerequisites
This design example is based on the Cyclone V GSRD and tested with Quartus II version 14.0. Refer to the
links listed below and review the recommended material before starting with this design example.

Related Information

• Cyclone V SoC Development Kit
Refer to this link for Cyclone V SoC Development Kit documentation and installation files.

• Golden System Reference Design User's Manual
Refer to this document and step through theGetting StartedGuides,Prerequisites, and theGHRDOverview.
In addition, review the Development Flow Overview.

Hardware Requirements

The hardware required for this design example is:

• Cyclone V SoC Development Kit
• RJ45 Ethernet cable
• SDMMC card preloaded with default GSRD image

Software Requirements

The software required for this design example is:

• Quartus II 14.0 and above
• SoC EDS 14.0 and above
• Factory default hardware template cv_soc_devkit_ghrd in SoC EDS 14.0

Design example files are provided in the AN 706 design example link and are listed in the table below.

Table 2: Required Software Files

DescriptionFile Name

Top level RTL fileghrd_top.v

Timing constraint filesoc_system_timing.sdc

Pin assignment script filean706_de_pin_assignment.tcl

Generated preloader binary targeted to this projectpreloader-mkpimage.bin

Modified u-boot image for EMAC0u-boot.img

Modified device tree for EMAC0 and I2C0socfpga.dtb
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Getting Started
1. Make a copy of the Cyclone V Golden Hardware Reference Design (GHRD) from your Cyclone

V SoC Development Kit installation location or download the latest Cyclone V GHRD design example
from the Rocketboards website to your project location.

2. Download the AN 706 design files (an706-design-files.zip) provided.
3. Open the GHRD project within the Quartus II software.

Generating the Initial HDL in Qsys
1. In the Quartus II navigation bar, select Tools > Qsys.
2. In the Qsys window, select File > Open > soc_system.qsys.
3. In the System Contents tab, double click on hps_0 to open the HPS Parameters window.

Figure 2: System Contents Window

4. On the Peripheral Pins tab, under the Ethernet Media Access Controller section, click on the EMAC0
pin pull-down and select FPGA. The EMAC0 mode pull-down automatically displays Full to indicate
GMII mode. Select the EMAC1 pin pull-down as Unused.
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Figure 3: Selecting FPGA for EMAC0 Pin in the HPS Parameters Window

5. On the Peripheral Pins tab, scroll down to the I2CControllers section, click on the I2C0 pin pull-down
and select FPGA. The I2C0 mode pull-down automatically displays Full.

Figure 4: Selecting FPGA for I2C0 Pin in the HPS Parameters Window

6. Return to the System Contents tab and in the Export column, double-click on the EMAC0 and I2C0
signal pins to export them as conduits.
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Figure 5: Exporting Pins in System Contents Window

7. Select Generate > Generate HDL from the Qsys menu bar. In the project directory, replace the top level
RTL file, ghrd_top.v, with the generated Verilog file.
Qsys exposes the following EMAC0 and I2C0 interfaces in the file:

Table 3: EMAC0 Signals in the FPGA Domain

DescriptionDirectionWidthSignal

PHY Transmit DataOut8emac0_phy_txd_o

PHY Transmit Data EnableOut1emac0_phy_txen_o

PHY Transmit ErrorOut1emac0_phy_txer_o

PHY Receive Data ValidIn1emac0_phy_rxdv_i

PHY Receive ErrorIn1emac0_phy_rxer_i

PHY Receive DataIn8emac0_phy_rxd_i

PHY Collision DetectIn1emac0_phy_col_i

PHY Carrier SenseIn1emac0_phy_crs_i

MDIO signal data outOut1emac0_gmii_mdo_o
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DescriptionDirectionWidthSignal

MDIO signal output enableOut1emac0_gmii_mdo_
o_e

MDIO signal inputIn1emac0_gmii_mdi_i

Management Data ClockOut1emac0_gmii_mdc_o

PHY RX reference clockIn1emac0_clk_rx_i

PHY TX reference clockIn1emac0_clk_tx_i

Transmit clock output to the PHYOut1emac0_phy_txclk_o

Transmit clock reset output to the
FPGA interface

Out1emac0_rst_clk_tx_n_
o

Receive clock reset outputOut1emac0_rst_clk_rx_
n_o

Table 4: I2C0 Signals in the FPGA Domain

DescriptionDirectionWidthSignal

Outgoing I2C data
enable

Out1i2c0_out_data

Incoming I2C dataIn1i2c0_sda

Outgoing I2C clock
enable

Out1i2c0_clk_clk

Incoming I2C clock
source

In1i2c0_scl_in_clk

Related Information

• Ethernet Media Access Controller
Refer to the interface descriptions in the Ethernet Media Access Controller chapter of the HPS Technical
Reference Manual for more detailed GMII interface signal descriptions

• I2C Controller
Refer to the interface descriptions in the I2C Controller chapter of the HPS Technical Reference Manual
for more detailed I2C interface signal descriptions.

Top Level Routing
The top level RTL file defines the pin connections from the HPS EMAC0 to the Renesas MII PHY on the
Cyclone V SoC development board.

Because MII is a 4-bit data width protocol, connect only the lower 4-bits, emac0_phy_txd_o[3:0]
and emac0_phy_rxd_i[3:0], of EMAC0's RX and TX interface from the FPGA.

Note:
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Figure 6: Routing of the EMAC0 FPGA Interface to the On-board MII PHY
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HPS I2C0 is routed through the FPGA interface and acts as a master to various on-board I2C slaves:

• Two Octal Digital Power Supply Managers with EEPROM
• LCD
• RTC
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• EEPROM

A bi-directional buffer, alt_iobuff, must be added in the design to connect the I2C signals to an
external open drain IO. The buffer can be included by instantiating alt_iobuff in ghrd_top.v.

Note:

The following Verilog code shows the alt_iobuff instantiation for an I2C interface implemented through
the FPGA:

ALT_IOBUF scl_iobuf (.i(1'b0), .oe(scl_o_e), .o(scl_o), .io(fpga_i2c_scl)); //declared
bi-directional buffer for scl
ALT_IOBUF sda_iobuf (.i(1'b0), .oe(sda_o_e), .o(sda_o), .io(fpga_i2c_sda)); //declared
bi-directional buffer for sda

Related Information
alt_iobuff Primitive
Refer to the alt_iobuff primitive information for more information.

Timing Constraint Configuration
Replace the soc_system_timing.sdc file in your project directory with the soc_system_timing.sdc file provided
in the project folder. This new file is customized for the EMAC0 and I2C0 interface being tested on the
Cyclone V SoC development board.

Quartus II Pin Assignments
1. Copy an706_de_pin_assignment.tcl from the AN 706 design files into your project directory.
2. In the Quartus II menu bar, select Tools > Tcl Scripts
3. In the Tcl Scripts window, choose an706_de_pin_assignment.tcl and select Run.

AN 706: Mapping HPS IP Peripheral Signals to the FPGA InterfaceAltera Corporation

Send Feedback

an-706
Timing Constraint Configuration10 2014.07.17

http://quartushelp.altera.com/13.0/mergedProjects/hdl/prim/prim_file_alt_iobuf.htm
http://www.altera.com/support/examples/soc/exm-hps-fpga-interface.html
mailto:TechDocFeedback@altera.com?subject=Feedback%20on%20AN%20706:%20Mapping%20HPS%20IP%20Peripheral%20Signals%20to%20the%20FPGA%20Interface%20(an-706%202014.07.17)&body=We%20appreciate%20your%20feedback.%20In%20your%20comments,%20also%20specify%20the%20page%20number%20or%20paragraph.%20Thank%20you.


Figure 7: Selecting pin_assigment.tcl in the Tcl Scripts Window

The an706_de_pin_assignment.tcl script automatically assigns EMAC0 and I2C0 signal pins to their related
FPGA pin location.

Table 5: Quartus Pin Assignments for EMAC0 and I2C0

Pin LocationDirectionSignal

PIN_Y24Inputenet1_rx_clk

PIN_AB23Inputenet1_rx_d[0]

PIN_AA24Inputenet1_rx_d[1]

PIN_AB25Inputenet1_rx_d[2]

PIN_AE27Inputenet1_rx_d[3]
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Pin LocationDirectionSignal

PIN_Y23Inputenet1_rx_dv

PIN_AE28Inputenet1_rx_error

PIN_W25Inputenet1_tx_clk_fb

PIN_W20Outputenet1_tx_d[0]

PIN_Y21Outputenet1_tx_d[1]

PIN_AA25Outputenet1_tx_d[2]

PIN_AB26Outputenet1_tx_d[3]

PIN_AB22Outputenet1_tx_en

PIN_AG5Outputenet1_tx_error

PIN_AJ1Outputenet_dual_resetn

PIN_H12Outputenet_fpga_mdc

PIN_H13Bidirectionalenet_fpga_mdio

PIN_G7Bidirectionalfpga_i2c_scl

PIN_F6Bidirectionalfpga_i2c_sda

Hardware Programming File Compilation and Generation
After the Qsys system is set up, the top level RTL file updated, the related signal pin location assigned and
timing constrained, the design can be compiled and the SOF programming file generated.

In Quartus II software navigation bar, select Processing > Start Compilation to generate the SOF
programming file.

SD Card Image Updates
Update the default SD card image with the generated preloader binary, u-boot image file and DTB file
following the steps described below:

1. With your Linux machine, prepare the SD card by following the information in GSRD-Booting Linux
UsingPrebuilt SDCard Image. Untar the sd_image.bin.tar.gz file and program the image file, sd_image.bin
into the SD card.

2. Replace the preloader-mkpimage.bin, u-boot.img and socfpga.dtb in the SD card.

Information provided regarding SD card changes, preloader and Linux software file changes and
preloader generation are applicable to this reference design only.

Note:
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Preloader Generation

Because this design example modifies the default GHRD Qsys file, it is essential to re-generate the preloader
with the preloader generator.

Related Information
GSRD- Generating and Compiling the Preloader
Refer to this location for information on how to generate and compile the preloader.

U-boot Setup

Go to file location u-boot-socfpga/include/configs/socfpga_cyclone.h. The EMAC0 parameters associatedwith
the interface speed must be configured to MII in the socfpga_cyclone.h file in the u-boot source. Change the
#define for CONFIG_EMAC_BASE and CONFIG_PHY_INTERFACE_MODE to the following:

#define CONFIG_EMAC_BASE CONFIG_EMAC0_BASE
#define CONFIG_PHY_INTERFACE_MODE SOCFPGA_PHYSEL_ENUM_MII

Related Information
U-Boot Customization
Refer to this location for information on how to customize u-boot.

Device Tree Setup

Generate the device tree. EMAC0 is enabled in the device tree source, as shown below, and the I2C0 code
source maintains its default settings.

aliases {
ethernet0 = "/soc/ethernet@ff700000";

};
ethernet@ff700000 {

compatible = "altr,socfpga-stmmac","snps,dwmac-3.70a", "snps,dwmac";

reg = <0xff700000 0x2000>;
interrupts = <0x0 0x73 0x4>;
interrupt-names = "macirq";
mac-address = [00 00 00 00 00 00];
clocks = <0xd>;
clock-names = "stmmaceth";
status = "okay";
phy-mode = "mii";
phy-add r= <0xffffffff>;
snsp,

};

Related Information
GSRD User Manual - Device Tree Generator
Refer to this location for information on device tree generation.

Board Setup and Booting Linux from the SD Card

Before you begin

Board setup is based on the GSRD Getting Started Guides.

1. Connect Ethernet Cable to the ENET1 Ethernet port.
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Figure 8: Ethernet Connection on Cyclone V SoC Development Board

2. Slot in the SD card and power on the board.
3. Program the FPGA .sof file and perform a warm reset on the HPS component to reload the SD card

image.
4. The kernel automatically enables and initializes EMAC0 then executes the dynamic host configuration

protocol (DHCP) to obtain an IP address.
5. When the boot process has completed, login as root at the kernel terminal.

Figure 9: Kernel Login Example
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Related Information

• GSRD User Manual - Getting Started Guide
Refer to this location for information on board setup in theGSRDUser'sManual - Getting StartedGuides.

• GSRD - SD Card
Refer to this location for information on updating the SD Card.

Sample Application Example
The default kernel image contains many useful commands and built-in tools, such as ethtools and mii-tools.
Some examples are illustrated in this section.

EMAC Test
Examples of commands that can be executed on EMAC0 are:

>udhcpc

Activate the dhcp server to request an IP address.
Figure 10: udhcpc Command Output

>ifconfig eth0

Initialize and enable or disable the network interface.
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Figure 11: ifconfig eth0 Command Output

>ethtool eth0

Display and allow edits to the EMAC device parameters.
Figure 12: ethtool eth0 Command Output

I2C Test
The I2C interface can be tested using the following commands:

>i2cdetect -l

List the detected HPS I2C ports.

>i2cdetect -r 0

List the I2C slave devices connected to the HPS. "UU" is defined as device busy.
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Figure 13: i2cdetect Command Outputs

>i2cset -y 0 0x66 0x10 0x55

I2C0 writes the data value 0x55 to the data address 0x10 of slave device at 0x66. The command is written in
the order: device address, data address, data value.

>i2cget -y 0 0x66 0x10

Return data value at address 0x10 of the device slave at address 0x66.
Figure 14: i2cset and i2cget Commands

>i2cdump -y 0 0x66

Register data dump from 0x00 to 0xFF. "XX" is defined as a non-valid address.
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Figure 15: i2cdump Command Output

Reference Documents
A summary list of the reference documents and sites mentioned in this application note follows:

Related Information

• HPS-to-FPGA Application Note (AN 706) Design Files

• Cyclone V SoC Development Kit

• Golden System Reference Design User's Manual

• Compiling Golden Hardware Reference Design

• Ethernet Media Access Controller

• I2C Controller

• alt_iobuff Primitive

• GSRD-Booting Linux Using Prebuilt SD Card Image

• GSRD- Generating and Compiling the Preloader

• U-Boot Customization

• GSRD User Manual - Device Tree Generator

• GSRD User Manual - Getting Started Guide

• GSRD - SD Card

• RocketBoards website
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http://quartushelp.altera.com/13.0/mergedProjects/hdl/prim/prim_file_alt_iobuf.htm
http://www.rocketboards.org/foswiki/Documentation/GSRD140BootLinuxSd
http://www.rocketboards.org/foswiki/Documentation/GSRD140Preloader
http://www.rocketboards.org/foswiki/Documentation/PreloaderUbootCustomization131#Common_Customization_Recipes
http://www.rocketboards.org/foswiki/Documentation/DeviceTreeGenerator140
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